// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/([a-zA-Z]{2})\/([a-zA-Z]{1,10})(\/.*$)").unwrap();
let string = "/it/xyz/test/param+1/param-2/1234/gfd4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}