const regex = /(Sample2).*(\d{2}-\d{2}-\d{4}).*(?<=[a-z]_)(\d+)(?=_\d+).*(?<=_)(\d+)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Sample2).*(\\d{2}-\\d{2}-\\d{4}).*(?<=[a-z]_)(\\d+)(?=_\\d+).*(?<=_)(\\d+)$', 'i')
const str = `Sample1_Sample2_1_05-11-2015_0_Sample3-AB_C_D_045_4_Sample4_123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}