import re
regex = re.compile(r"(Sample2).*(\d{2}-\d{2}-\d{4}).*(?<=[a-z]_)(\d+)(?=_\d+).*(?<=_)(\d+)$", flags=re.IGNORECASE)
test_str = "Sample1_Sample2_1_05-11-2015_0_Sample3-AB_C_D_045_4_Sample4_123456"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")