$re = '/(Sample2).*(\d{2}-\d{2}-\d{4}).*(?<=[a-z]_)(\d+)(?=_\d+).*(?<=_)(\d+)$/i';
$str = 'Sample1_Sample2_1_05-11-2015_0_Sample3-AB_C_D_045_4_Sample4_123456';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);