#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\[\/?(?:b|i|u|sup|url|image|color|size|font){1,}.*?]"
Local $sString = "Test" & @CRLF & _
"Te[b]st[/b]" & @CRLF & _
"Tes[font]t[/font]" & @CRLF & _
"Test[Custom]Oh no![/Custom]" & @CRLF & _
"Test[color=red]With attr[/b][/i][/u][/color]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")