import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\/?(?:b|i|u|sup|url|image|color|size|font){1,}.*?]";
final String string = "Test\n"
+ "Te[b]st[/b]\n"
+ "Tes[font]t[/font]\n"
+ "Test[Custom]Oh no![/Custom]\n"
+ "Test[color=red]With attr[/b][/i][/u][/color]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}