package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[\/?(?:b|i|u|sup|url|image|color|size|font){1,}.*?]`)
var str = `Test
Te[b]st[/b]
Tes[font]t[/font]
Test[Custom]Oh no![/Custom]
Test[color=red]With attr[/b][/i][/u][/color]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}