const regex = /(.*)(?:http:\/\/thepaperwall\.com\/wallpapers\/.*\.jpg)(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(?:http:\\\/\\\/thepaperwall\\.com\\\/wallpapers\\\/.*\\.jpg)(.*)', '')
const str = `test test http://thepaperwall.com/wallpapers/cityscape/small/small_642331afcd78d0840485bb352d99b289b50e8467.jpg test test `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}