import Foundation
let pattern = #"(.*)(?:http:\/\/thepaperwall\.com\/wallpapers\/.*\.jpg)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"test test http://thepaperwall.com/wallpapers/cityscape/small/small_642331afcd78d0840485bb352d99b289b50e8467.jpg test test "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}