re = /(.*)(?:http:\/\/thepaperwall\.com\/wallpapers\/.*\.jpg)(.*)/
str = 'test test http://thepaperwall.com/wallpapers/cityscape/small/small_642331afcd78d0840485bb352d99b289b50e8467.jpg test test '
# Print the match result
str.match(re) do |match|
puts match.to_s
end