$re = '/(.*)(?:http:\/\/thepaperwall\.com\/wallpapers\/.*\.jpg)(.*)/';
$str = 'test test http://thepaperwall.com/wallpapers/cityscape/small/small_642331afcd78d0840485bb352d99b289b50e8467.jpg test test ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);