import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*?\\d{3}( |-|.)?\\d{4})((?:\\+?(?:1)(?:\\1|\\s*?))?(?:(?:\\d{3}\\s*?)|(?:\\((?:\\d{3})\\)\\s*?))\\1?(?:\\d{3})\\1?(?:\\d{4})(?:\\s*?(?:#|(?:ext\\.?))(?:\\d{1,5}))?)\\b";
final String string = "+1-855-419-0101 #807\n"
+ "1-855-419-0101 ext807\n"
+ "Tél.: 450-419-0100 #807\n"
+ "1 877 776-5743\n"
+ "1 877 776 5743 patate\n"
+ "1 877 776 57433\n"
+ "1 877 776 5743\n"
+ "3877 776 5743\n"
+ "514 555 9457\n"
+ "(514)555-9457\n"
+ "(514) 555-9457 Ext.333\n"
+ "15145557984\n"
+ "514.795.7777";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}