import re
regex = re.compile(r"(?=.*?\d{3}( |-|.)?\d{4})((?:\+?(?:1)(?:\1|\s*?))?(?:(?:\d{3}\s*?)|(?:\((?:\d{3})\)\s*?))\1?(?:\d{3})\1?(?:\d{4})(?:\s*?(?:#|(?:ext\.?))(?:\d{1,5}))?)\b", flags=re.IGNORECASE)
test_str = ("+1-855-419-0101 #807\n"
"1-855-419-0101 ext807\n"
"Tél.: 450-419-0100 #807\n"
"1 877 776-5743\n"
"1 877 776 5743 patate\n"
"1 877 776 57433\n"
"1 877 776 5743\n"
"3877 776 5743\n"
"514 555 9457\n"
"(514)555-9457\n"
"(514) 555-9457 Ext.333\n"
"15145557984\n"
"514.795.7777")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")