use strict;
my $str = '+1-855-419-0101 #807
1-855-419-0101 ext807
Tél.: 450-419-0100 #807
1 877 776-5743
1 877 776 5743 patate
1 877 776 57433
1 877 776 5743
3877 776 5743
514 555 9457
(514)555-9457
(514) 555-9457 Ext.333
15145557984
514.795.7777';
my $regex = qr/(?=.*?\d{3}( |-|.)?\d{4})((?:\+?(?:1)(?:\1|\s*?))?(?:(?:\d{3}\s*?)|(?:\((?:\d{3})\)\s*?))\1?(?:\d{3})\1?(?:\d{4})(?:\s*?(?:#|(?:ext\.?))(?:\d{1,5}))?)\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}