re = /(?=.*?\d{3}( |-|.)?\d{4})((?:\+?(?:1)(?:\1|\s*?))?(?:(?:\d{3}\s*?)|(?:\((?:\d{3})\)\s*?))\1?(?:\d{3})\1?(?:\d{4})(?:\s*?(?:#|(?:ext\.?))(?:\d{1,5}))?)\b/i
str = '+1-855-419-0101 #807
1-855-419-0101 ext807
Tél.: 450-419-0100 #807
1 877 776-5743
1 877 776 5743 patate
1 877 776 57433
1 877 776 5743
3877 776 5743
514 555 9457
(514)555-9457
(514) 555-9457 Ext.333
15145557984
514.795.7777'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end