package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]\d{3}$`)
var str = `PASS :
A043
C027
C151
Z008
FAIL :
ABCD
1234
AB12
-123
_123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}