const regex = /^[A-Z]\d{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]\\d{3}$', 'gm')
const str = `PASS :
A043
C027
C151
Z008
FAIL :
ABCD
1234
AB12
-123
_123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}