import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]\\d{3}$";
final String string = "PASS :\n"
+ "A043\n"
+ "C027\n"
+ "C151\n"
+ "Z008\n\n"
+ "FAIL :\n"
+ "ABCD\n"
+ "1234\n"
+ "AB12\n"
+ "-123\n"
+ "_123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}