$re = '/^[A-Z]\d{3}$/m';
$str = 'PASS :
A043
C027
C151
Z008
FAIL :
ABCD
1234
AB12
-123
_123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);