use strict;
my $str = ' <p>Hello</p>
<p>world</p>
<p>jjejejejjeje</p>
#->allo
<code>#un_lien_ignore jgeijdejdehdej et #un_autre pis celui là! egalement #!ignore_moi</code>
<a href="ceci nes pas un tag">li</a><a href="ceci n\'est #pas un tag">li</a>
mais #->moi_j\'en_suis_un #!important_avec_un_lien
<span>
#!pasmoi
#->moisnon
#->pasoim
#->lol
</span>
[->]
[->][->][->][->][->]
[<-][<-][<-][<-][<-][<-][<-][<-]
[->][->][->][->][->]
[->][->][->][->][->]
#lien
#des_tags encore #école #stratégie
[->][->][->][->][->]
[->][->][->][->][->] et et encore #->avec un lien et #sans_lien chose qui devrait # !matcher encore #un_tag et un #autre_avec_un_lien';
my $regex = qr~#(!->|->|!)*(\w|\')+(?![^<]*[]>|[^<>]*<\/)~up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}