$re = '~#(!->|->|!)*(\w|\')+(?![^<]*[]>|[^<>]*<\/)~u';
$str = ' <p>Hello</p>
<p>world</p>
<p>jjejejejjeje</p>
#->allo
<code>#un_lien_ignore jgeijdejdehdej et #un_autre pis celui là! egalement #!ignore_moi</code>
<a href="ceci nes pas un tag">li</a><a href="ceci n\'est #pas un tag">li</a>
mais #->moi_j\'en_suis_un #!important_avec_un_lien
<span>
#!pasmoi
#->moisnon
#->pasoim
#->lol
</span>
[->]
[->][->][->][->][->]
[<-][<-][<-][<-][<-][<-][<-][<-]
[->][->][->][->][->]
[->][->][->][->][->]
#lien
#des_tags encore #école #stratégie
[->][->][->][->][->]
[->][->][->][->][->] et et encore #->avec un lien et #sans_lien chose qui devrait # !matcher encore #un_tag et un #autre_avec_un_lien';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);