# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#(!->|->|!)*(\w|\')+(?![^<]*[]>|[^<>]*<\/)"
test_str = (" <p>Hello</p>\n"
" <p>world</p>\n"
" <p>jjejejejjeje</p>\n"
"#->allo\n"
" <code>#un_lien_ignore jgeijdejdehdej et #un_autre pis celui là! egalement #!ignore_moi</code>\n"
" <a href=\"ceci nes pas un tag\">li</a><a href=\"ceci n'est #pas un tag\">li</a> \n\n"
"mais #->moi_j'en_suis_un #!important_avec_un_lien\n"
"<span>\n"
"#!pasmoi\n"
"#->moisnon\n"
"#->pasoim\n"
"#->lol\n\n"
"</span>\n"
"[->]\n"
"[->][->][->][->][->]\n"
"[<-][<-][<-][<-][<-][<-][<-][<-]\n\n"
"[->][->][->][->][->]\n"
"[->][->][->][->][->]\n\n"
" #lien\n"
" #des_tags encore #école #stratégie\n"
"[->][->][->][->][->]\n"
"[->][->][->][->][->] et et encore #->avec un lien et #sans_lien chose qui devrait # !matcher encore #un_tag et un #autre_avec_un_lien")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.