using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<rsag>\w+)=(?<value>"".*?""|\S+)";
string input = @"foo=2 bar=3 apple=""hello"" msg=""hello world"" host=""stackoverflow.com""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}