import re
regex = re.compile(r"(?<rsag>\w+)=(?<value>\".*?\"|\S+)")
test_str = "foo=2 bar=3 apple=\"hello\" msg=\"hello world\" host=\"stackoverflow.com\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")