re = /(?<rsag>\w+)=(?<value>".*?"|\S+)/
str = 'foo=2 bar=3 apple="hello" msg="hello world" host="stackoverflow.com"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end