$re = '/(?<rsag>\w+)=(?<value>".*?"|\S+)/';
$str = 'foo=2 bar=3 apple="hello" msg="hello world" host="stackoverflow.com"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);