# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*(.*?)\s*$/$1/gm;t' <<< "Spaces at the end
Spaces on both sides
Space a the beginning
no spaces around this string
"