#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*(.*?)\s*$"
Local $sString = "Spaces at the end " & @CRLF & _
" Spaces on both sides " & @CRLF & _
" Space a the beginning" & @CRLF & _
"no spaces around this string" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)