package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(.*?)\s*$`)
var str = `Spaces at the end
Spaces on both sides
Space a the beginning
no spaces around this string
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}