use strict;
my $str = 'Spaces at the end
Spaces on both sides
Space a the beginning
no spaces around this string
';
my $regex = qr/^\s*(.*?)\s*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";