using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-|\*|[0-9]+.) \[ \]";
string input = @"- [ ]
-[]
- []
-[x]
- [X]
1. [ ]
2. [x]
11. []
2125. [ ]
. [ ] // Fixed with + instead of *
1. [ ] #TODO #experiments **Zephyr** Use external Groove:
1. [ ] Board LED turning on.
2. [ ] Buzzer making sound.
3. [ ] Neo Pixel LED turning on with rainbow pattern.
4. [ ] Neo Pixel LED switching on/off state.
5. [ ] Neo Pixel LED switching different patterns.
6. [ ] OLED screen showing some text.
7. [ ] OLED screen showing some images.
8. [ ] Combination of 2
9. [ ] Combination of all!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}