use strict;
my $str = '- [ ]
-[]
- []
-[x]
- [X]
1. [ ]
2. [x]
11. []
2125. [ ]
. [ ] // Fixed with + instead of *
1. [ ] #TODO #experiments **Zephyr** Use external Groove:
1. [ ] Board LED turning on.
2. [ ] Buzzer making sound.
3. [ ] Neo Pixel LED turning on with rainbow pattern.
4. [ ] Neo Pixel LED switching on/off state.
5. [ ] Neo Pixel LED switching different patterns.
6. [ ] OLED screen showing some text.
7. [ ] OLED screen showing some images.
8. [ ] Combination of 2
9. [ ] Combination of all!';
my $regex = qr/(-|\*|[0-9]+.) \[ \]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}