# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(-|\*|[0-9]+.) \[ \]"
test_str = ("- [ ]\n"
"-[] \n"
"- []\n"
"-[x]\n"
"- [X] \n"
"1. [ ]\n"
"2. [x]\n"
"11. [] \n"
"2125. [ ] \n"
". [ ] // Fixed with + instead of *\n\n"
"1. [ ] #TODO #experiments **Zephyr** Use external Groove:\n"
" 1. [ ] Board LED turning on.\n"
" 2. [ ] Buzzer making sound.\n"
" 3. [ ] Neo Pixel LED turning on with rainbow pattern.\n"
" 4. [ ] Neo Pixel LED switching on/off state.\n"
" 5. [ ] Neo Pixel LED switching different patterns.\n"
" 6. [ ] OLED screen showing some text.\n"
" 7. [ ] OLED screen showing some images.\n"
" 8. [ ] Combination of 2\n"
" 9. [ ] Combination of all!")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.