package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(cm_mmc).*(-_-).*(-_-).*(-_-)`)
var str = `http://m.macys.com/shop/makeup-and-perfume/cologne-for-men?id=30088&edge=hybrid&cm_sp=us_hdr-_-beauty30088_cologne-&-grooming_COL3&cm_mmc=Carat_Social-_-facebook-_-jun2_frag_dad_gwp_fb_dr_roas_u6050067_11707_1420538-_-06062016_06162016&dclid=COjhz-annc0CFQ8FgQod-ycCPA`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}