const regex = new RegExp('(cm_mmc).*(-_-).*(-_-).*(-_-)', '')
const str = `http://m.macys.com/shop/makeup-and-perfume/cologne-for-men?id=30088&edge=hybrid&cm_sp=us_hdr-_-beauty30088_cologne-&-grooming_COL3&cm_mmc=Carat_Social-_-facebook-_-jun2_frag_dad_gwp_fb_dr_roas_u6050067_11707_1420538-_-06062016_06162016&dclid=COjhz-annc0CFQ8FgQod-ycCPA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}