import Foundation
let pattern = #"(cm_mmc).*(-_-).*(-_-).*(-_-)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://m.macys.com/shop/makeup-and-perfume/cologne-for-men?id=30088&edge=hybrid&cm_sp=us_hdr-_-beauty30088_cologne-&-grooming_COL3&cm_mmc=Carat_Social-_-facebook-_-jun2_frag_dad_gwp_fb_dr_roas_u6050067_11707_1420538-_-06062016_06162016&dclid=COjhz-annc0CFQ8FgQod-ycCPA"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}