using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z0-9,.'!-]+";
string substitution = @"";
string input = @"20010db8 ~~ 0a0b:12f0:0000:0 000:0000:0001~!!!!!!!!5423462554&%^%*&%^^&%&^%&#$%@!@#!#!@%!^#$*^* fdsfdsfsdfsdasddsaas dQQWQWQWQWraerrewq rewr ew rewdasdFSD FSDF SDFSD FSD FSD FSD FSD ~~~@!#@#@fsdfsdf fds fds fsd fdsfsd f fsd fsd fsd fsd fsdfds";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}