// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z0-9,.'!-]+").unwrap();
let string = "20010db8 ~~ 0a0b:12f0:0000:0 000:0000:0001~!!!!!!!!5423462554&%^%*&%^^&%&^%&#$%@!@#!#!@%!^#$*^* fdsfdsfsdfsdasddsaas dQQWQWQWQWraerrewq rewr ew rewdasdFSD FSDF SDFSD FSD FSD FSD FSD ~~~@!#@#@fsdfsdf fds fds fsd fdsfsd f fsd fsd fsd fsd fsdfds";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}