package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z0-9,.'!-]+`)
var str = []byte(`20010db8 ~~ 0a0b:12f0:0000:0 000:0000:0001~!!!!!!!!5423462554&%^%*&%^^&%&^%&#$%@!@#!#!@%!^#$*^* fdsfdsfsdfsdasddsaas dQQWQWQWQWraerrewq rewr ew rewdasdFSD FSDF SDFSD FSD FSD FSD FSD ~~~@!#@#@fsdfsdf fds fds fsd fdsfsd f fsd fsd fsd fsd fsdfds`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}