#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(" & @CRLF & _
"\+?" & @CRLF & _
" (?:" & @CRLF & _
" (?:" & @CRLF & _
" 9[976]\d" & @CRLF & _
" |" & @CRLF & _
" 8[987530]\d" & @CRLF & _
" |" & @CRLF & _
" 6[987]\d" & @CRLF & _
" |" & @CRLF & _
" 5[90]\d" & @CRLF & _
" |" & @CRLF & _
" 42\d" & @CRLF & _
" |" & @CRLF & _
" 3[875]\d" & @CRLF & _
" |" & @CRLF & _
" 2[98654321]\d" & @CRLF & _
" |" & @CRLF & _
" 9[8543210]" & @CRLF & _
" |" & @CRLF & _
" 8[6421]" & @CRLF & _
" |" & @CRLF & _
" 6[6543210]" & @CRLF & _
" |" & @CRLF & _
" 5[87654321]" & @CRLF & _
" |" & @CRLF & _
" 4[987654310]" & @CRLF & _
" |" & @CRLF & _
" 3[9643210]" & @CRLF & _
" |" & @CRLF & _
" 2[70]" & @CRLF & _
" |" & @CRLF & _
" 7" & @CRLF & _
" |" & @CRLF & _
" 0" & @CRLF & _
"|" & @CRLF & _
"1" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" |" & @CRLF & _
"" & @CRLF & _
" \(" & @CRLF & _
" (?:" & @CRLF & _
" 9[976]\d" & @CRLF & _
" |" & @CRLF & _
" 8[987530]\d" & @CRLF & _
" |" & @CRLF & _
" 6[987]\d" & @CRLF & _
" |" & @CRLF & _
" 5[90]\d" & @CRLF & _
" |" & @CRLF & _
" 42\d" & @CRLF & _
" |" & @CRLF & _
" 3[875]\d" & @CRLF & _
" |" & @CRLF & _
" 2[98654321]\d" & @CRLF & _
" |" & @CRLF & _
" 9[8543210]" & @CRLF & _
" |" & @CRLF & _
" 8[6421]" & @CRLF & _
" |" & @CRLF & _
" 6[6543210]" & @CRLF & _
" |" & @CRLF & _
" 5[87654321]" & @CRLF & _
" |" & @CRLF & _
" 4[987654310]" & @CRLF & _
" |" & @CRLF & _
" 3[9643210]" & @CRLF & _
" |" & @CRLF & _
" 2[70]" & @CRLF & _
" |" & @CRLF & _
" 7" & @CRLF & _
" |" & @CRLF & _
" 1" & @CRLF & _
" )" & @CRLF & _
" \))" & @CRLF & _
"[0-9. -]{4,14}" & @CRLF & _
")(?:\b|x\d+)"
Local $sString = "+86-400-660-8680" & @CRLF & _
"+86-400-660-8680" & @CRLF & _
"+1 888 204 3539" & @CRLF & _
"1-800-667-6389" & @CRLF & _
"+1-400-660-8680" & @CRLF & _
"(877) 359-6695" & @CRLF & _
"800-692-7753" & @CRLF & _
"0365987456" & @CRLF & _
"+3342568795" & @CRLF & _
"05987213" & @CRLF & _
"+33 321 82" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")