import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\n"
+ "\\+?\n"
+ " (?:\n"
+ " (?:\n"
+ " 9[976]\\d\n"
+ " |\n"
+ " 8[987530]\\d\n"
+ " |\n"
+ " 6[987]\\d\n"
+ " |\n"
+ " 5[90]\\d\n"
+ " |\n"
+ " 42\\d\n"
+ " |\n"
+ " 3[875]\\d\n"
+ " |\n"
+ " 2[98654321]\\d\n"
+ " |\n"
+ " 9[8543210]\n"
+ " |\n"
+ " 8[6421]\n"
+ " |\n"
+ " 6[6543210]\n"
+ " |\n"
+ " 5[87654321]\n"
+ " |\n"
+ " 4[987654310]\n"
+ " |\n"
+ " 3[9643210]\n"
+ " |\n"
+ " 2[70]\n"
+ " |\n"
+ " 7\n"
+ " |\n"
+ " 0\n"
+ "|\n"
+ "1\n"
+ " )\n\n"
+ " |\n\n"
+ " \\(\n"
+ " (?:\n"
+ " 9[976]\\d\n"
+ " |\n"
+ " 8[987530]\\d\n"
+ " |\n"
+ " 6[987]\\d\n"
+ " |\n"
+ " 5[90]\\d\n"
+ " |\n"
+ " 42\\d\n"
+ " |\n"
+ " 3[875]\\d\n"
+ " |\n"
+ " 2[98654321]\\d\n"
+ " |\n"
+ " 9[8543210]\n"
+ " |\n"
+ " 8[6421]\n"
+ " |\n"
+ " 6[6543210]\n"
+ " |\n"
+ " 5[87654321]\n"
+ " |\n"
+ " 4[987654310]\n"
+ " |\n"
+ " 3[9643210]\n"
+ " |\n"
+ " 2[70]\n"
+ " |\n"
+ " 7\n"
+ " |\n"
+ " 1\n"
+ " )\n"
+ " \\))\n"
+ "[0-9. -]{4,14}\n"
+ ")(?:\\b|x\\d+)";
final String string = "+86-400-660-8680\n"
+ "+86-400-660-8680\n"
+ "+1 888 204 3539\n"
+ "1-800-667-6389\n"
+ "+1-400-660-8680\n"
+ "(877) 359-6695\n"
+ "800-692-7753\n"
+ "0365987456\n"
+ "+3342568795\n"
+ "05987213\n"
+ "+33 321 82\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}