package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(
\+?
(?:
(?:
9[976]\d
|
8[987530]\d
|
6[987]\d
|
5[90]\d
|
42\d
|
3[875]\d
|
2[98654321]\d
|
9[8543210]
|
8[6421]
|
6[6543210]
|
5[87654321]
|
4[987654310]
|
3[9643210]
|
2[70]
|
7
|
0
|
1
)
|
\(
(?:
9[976]\d
|
8[987530]\d
|
6[987]\d
|
5[90]\d
|
42\d
|
3[875]\d
|
2[98654321]\d
|
9[8543210]
|
8[6421]
|
6[6543210]
|
5[87654321]
|
4[987654310]
|
3[9643210]
|
2[70]
|
7
|
1
)
\))
[0-9. -]{4,14}
)(?:\b|x\d+)`)
var str = `+86-400-660-8680
+86-400-660-8680
+1 888 204 3539
1-800-667-6389
+1-400-660-8680
(877) 359-6695
800-692-7753
0365987456
+3342568795
05987213
+33 321 82
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}