using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://www\.google\.co\.uk/(?!.*=(?:isch|shop)$).*$";
string input = @"https://www.google.co.uk/search?q=SSD&tbm=isch
https://www.google.co.uk/search?q=SSD&tbm=shop
https://www.google.co.uk/search?q=SSD&tbm=other";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}