re = /https:\/\/www\.google\.co\.uk\/(?!.*=(?:isch|shop)$).*$/m
str = 'https://www.google.co.uk/search?q=SSD&tbm=isch
https://www.google.co.uk/search?q=SSD&tbm=shop
https://www.google.co.uk/search?q=SSD&tbm=other'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end