import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://www\\.google\\.co\\.uk/(?!.*=(?:isch|shop)$).*$";
final String string = "https://www.google.co.uk/search?q=SSD&tbm=isch\n"
+ "https://www.google.co.uk/search?q=SSD&tbm=shop\n"
+ "https://www.google.co.uk/search?q=SSD&tbm=other";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}