using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\Bing\b";
string substitution = @"";
string input = @"dreaming going ing king wings";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}