$re = '/\Bing\b/i';
$str = 'dreaming going ing king wings';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;