package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\Bing\b`)
var str = `dreaming going ing king wings`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}