const regex = /\Bing\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\Bing\\b', 'gi')
const str = `dreaming going ing king wings`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);