import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:((?:January|February|March|April|May|June|July|August|September|October|November|December) \\d+ at \\d+:\\d+[ap]m)|(Yesterday at \\d+:\\d+[ap]m)|(\\d+ hours ago)|(About an hour ago)) \\D*?(\\d+)?$";
final String string = "September 5 at 8:40pm · Like · 23\n"
+ "Yesterday at 5:35am · Like \n"
+ "10 hours ago · Like · 2\n"
+ "6 hours ago · Like";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}